Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GIMP 2.8 Large size Icons Themes
#31
The first question is; Have you successfully unpacked the 7z file?

There was a report from a Windows user that for some reason they got a second Color48 folder inside a first Color48 folder. You just need one as shown in an earlier screenshot.

Other wise, detailed instructions are

Unpack the .7z archive
Copy the Color48 folder to your gimp profile  C:\Users\your-name\.gimp-2.8\themes
Open Gimp.
Go to Edit - > Preferences -> Themes  (edit oops needed to correct that one)
Click on the theme you want.
Ok it.
Restart Gimp

-------------
I thought I did a video on the subject Wink https://www.youtube.com/watch?v=bvFnxYkzKz0 only a couple of minutes

Use whatever archive manager you want but in that demo I used a free one peazip extractor from
http://www.peazip.org/peaextractor-unace...unzip.html
Reply
#32
Nope, doesn't work. Did everything according to the youtube video and the icons are exactly the same, tiny. I even uninstalled everything and reloaded and did everything again and followed the video exactly step by step.

Could it be my machine? I have a Surface, though I had a Surface 4 - it got busted and I got a new machine as the old one was under warranty, and the new one has more RAM and a bigger hd, but they won't call it a Surface 4 - I asked VERY specifically - but they fucking dodge and dodge - they absolutely won't call it a Surface 4. So I said, this isn't a Surface 4? It's a Surface. So, it's NOT a Surface Pro. And around and goddam around.

I have to say that the text and everything is normal sized at least - it's just the icons that remain the same.

Do I need to put the file into the gimp program file itself?

So I'm frustrated.
Reply
#33
Looking at the older posts, there are Surface - something users who get it working.

But if it does not work for you, then that theme is not going to work for you, so there was this suggestion

https://www.gimp-forum.net/Thread-GIMP-2...27#pid1127 post #12

and you could try the development version of Gimp 2.9.6 You can get a Windows version here http://www.partha.com
and the icons there are now independent of the theme and can be scaled up a bit.

see: https://www.gimp-forum.net/Thread-GIMP-2...72#pid2672 post #24
Reply
#34
Can you tell me where in GIMP 2.9 I can change the icon size? Thanks
Reply
#35
(11-25-2017, 06:14 PM)SearchKing Wrote: Can you tell me where in GIMP 2.9 I can change the icon size? Thanks

Go to Edit -> Preferences -> Icon Theme

Choose Custom icon size in the drop down box

Set the slider to Huge.

example screenshot: https://i.imgur.com/2r6rjpH.jpg
Reply
#36
NOTHING HAPPENS in 2.9

It won't let me move the custom icon to anything larger than medium, and nothing changes.

I'm trying to change the registry and follow the instructions as given by Dan on page 1 of this thread, but the instructions are unclear when it comes to what to do with the file in the actual program. I can't copy it to put into gimp 2, so now what?

I tried to do a screenshot but it's too big to post.
Reply
#37
(11-25-2017, 11:25 PM)SearchKing Wrote: NOTHING HAPPENS in 2.9

It won't let me move the custom icon to anything larger than medium, and nothing changes.

I'm trying to change the registry and follow the instructions as given by Dan on page 1 of this thread, but the instructions are unclear when it comes to what to do with the file in the actual program. I can't copy it to put into gimp 2, so now what?

I tried to do a screenshot but it's too big to post.

I'm on Windows 10 and I had to run gimp as an administrator in order for Windows to allow gimp to access the themes folder on C:\Program Files\GIMP 2\share\themes. Even though I put the theme in my appdata/.gimp/themes folder, because gimp is reading its default theme from the restricted programs folder, Windows considers the theme a restricted resources that it will not allow to be overwritten by a regular file. So, in order to apply the theme, you must run gimp as an administrator, choose the theme, close gimp, reopen it, and the the theme should be applied.

Windows 10 is so locked down it's a real pain in the rear. I tried moving the theme folder off of the program files into my user folder, but it made no difference. Once the theme is applied, Windows will not allow it to be changed except through an elevated process. I'm on the "Fall Creators Update" (ver. 1709), which, despite Microsoft finally allowing Android in (a little bit) appears to be the most restrictive operating system I have ever had the increasing misfortune to be subjected to.

Oh, I also meant to say: thanks for the big icons! I'm helping my sister set up her new laptop and, though she is legally blind, she can still see stuff if it's big enough. I tried the default icons at "huge" and they were still a bit blurry for her. But the 48px color set is definitely big enough for her to see (even if they take up a lot of screen space. Oh well!). These big icons are literally the determining factor for her ability to use gimp.

A million thanks. I can hardly believe this free and open source program is better than a certain very expense program that gimp gets compared to a lot. That expensive program will only work for severely vision-restricted people by being used with an extremely expensive (and gigantic) monitor -- and it might still be necessary to use magnification enhancements. I guess having that much money is great for those who have it, but my sister isn't one of them. Please know your efforts have made all the difference in one woman's life.
Reply
#38
(01-28-2017, 09:53 AM)SimpleMind Wrote: I had the same problem. Then I noticed when extracting it with 7-zip, it creates a "duplicate nested" subfolder. For example:
C:\Users\xxxxx\.gimp-2.8\themes\Color-48\Color-48\    (then a list of folders like 12, 16, 18, 22, etc)

Change this to:
C:\Users\xxxxx\.gimp-2.8\themes\Color-48\    (then a list of folders like 12, 16, 18, 22, etc)

That solved it for me. All themes, color and symbolic, show up.
Thanks for the themes.

Thanks! That solved it for me too.
Just need to restart gimp after changing the theme.
Reply
#39
Thank you for taking the time to make these themes for us.

I was able to activate the themes, but I have a small glitch.

The menu at the top of the Gimp page usually offers, "Files / Edit / Select / View / Image / Layer / Colors / Tools / Filters / Windows / Help.

In default themes that came with Gimp, these display as expected.

In any of the new themes I downloaded here, the first option: "Files" is visible, but the rest of the menu topping words are invisible.

If I hover over where they should be, I can see the menus still exist. Just the top word appears to be missing - marking the top of the menu.

Have I neglected to set something? Can you help?

Thank you.

Using Gimp 2.8.16 on Linux Mint 18.3 on Dell Inspiron 15 7000 series / 7568 with high res screen. (The high res screen is why I need larger icons.)

PS: Attaching screenshot JPEG - goes with my previous note about the menu at top of screen being partially invisible


Attached Files Thumbnail(s)
   
Reply
#40
Thank you. This theme has made GIMP much more usable on my Win10Pro hidpi display. But there is one more thing that I really wish could be addressed: in the toolbox and elsewhere, icons are now quite nice, but checkboxes are still really hard to click on and to see if they've been checked. Has anybody tried to fix those in a theme? Other form elements seem good (dropdowns/select boxes, text inputs) Thanks again. Here's a screenshot using the Color-48 theme. See the tiny checkboxes?

The screenshot actually looks really huge here on the web page, but check it relative to the gimp forum page behind it.

     
Reply


Forum Jump: