Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gimp does not start
Recently I've updated to Gimp 2.10. First time I tried it started, I selected a jpeg to open, then it hang (with no image shown and the file open dialog disabled). I vaguely remember an error output on the command line, complaining about missing "Python" (which is weird, because I have Python installed). After killing the software I tried again, this time no window came up at all. I've removed my .gimp folder, removed /etc/gimp, uninstalled gimp and all libraries and re-installed them again, same result. There's no difference whether I try from the command line, or from the KDE Gui.

Each time I try to start gimp from the command line, no output is shown at all, not even with --verbose. When I Ctrl+C, I get "Segmentation Fault". 
After starting gimp, there are four gimp threads present. That's it, no window, no command line output, nothing. No gimp.

Does any of you have an idea what else I could try?

I'd appreciate any kind of help.
All the best, Jacob.

(gimp --version gives 2.10.6, I'm on Debian Linux, testing (1 SMP Debian 4.17.17-1 (2018-08-18)), and I'm using KDE/Plasma.)
I have a Kubuntu 18.04 and Gimp 2.10.6 works there, I also have a PClinuxOS KDE (rpm based) and Gimp 2.10.6 installs very differently but also works.

Have you tried asking on a Debian forum? That would be the best place. I do not think there are many pure Debian users here.

An alternative is ask on where there might be some Debian users.

When it comes to Python, I am no expert but I think some of the 'cutting edge' distro's now come with python 3 only. Check that and if required install Python 2.7

edit: just looked at the distrowatch Debian packages list and it is a 2.7.x so not python 3

Forum Jump: