Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
'Heal Selection' Missing from Gimp on Ubuntu 20.04
I've just updated Ubuntu from version 19.10 to 20.04, and that has updated Gimp to 2.10.18.

One of the features that I regularly use is "Heal Selection" that appears in the Filters->Enhance menu, but it's absent from Ubuntu's Gimp.

I understand that the "Heal Selection" feature uses the Resynthesizer plugin, and in Ubuntu that is included in the "gimp-plugin-registry" package, a package that contains multiple plugins, and I do have that installed. The Resynthesizer's own menu entry is present in its usual place at Filters->Map->Resynthesize, but that doesn't include the "Heal Selection" feature.

On previous versions of Ubuntu (18.10 to 19.10), the gimp-python package also needed to be manually installed to make "Heal Selection" magically appear. This package is not in Ubuntu 20.04's repository. So this seems to be the core of the problem.

Anybody know why gimp-python has disappeared? Any ideas about what's going on at all, please?
Ubuntu 20.04 has moved onto Python 3 There are Python 2.7 packages available but as you found no gimp-python integration. Why ? ask ubuntu.

If you install the snap or the flatpak versions of Gimp then they come bundled with python and python plugins will work. What does not work is QT needed if you use the gimp-gmic-qt plugin.

An another alternative (apart from compiling Gimp yourself) is a Gimp appimage where both python and QT work.

Me, I am sticking with (k)ubuntu 18.04 until the mess gets sorted.
Another solution is to compile your own Gimp version... Not too hard.

Thanks all. I'd chopped out the flatpak subsystem because of the overheads, so I tried downloading Ubuntu 18.10's  gimp-python and installing it manually, fixing any dependencies it complained about, and amazingly it was really straightforward. Just two packages needed to be downloaded, which had no replacements to clash with, so although it's a bit of a hack, it seems safe enough. I'd already had to install a whole bunch of Python 2 packages for Inkscape, so the extra overhead wasn't significant for me. Heal-selection works. GMIC QT works.


sudo apt install gimp gimp-plugin-registry gimp-gmic
sudo apt install python python-cairo python-gobject-2

sudo dpkg -i python-gtk2_2.24.0-6_amd64.deb
sudo dpkg -i gimp-python_2.10.8-2_amd64.deb
Before you go any further. This will not work with Ubuntu 22.04 - too many dependency problems
If you have installed a ubuntu 22.04 LTS or a spin-off kubuntu / Mint ... Then installing the old python packages is a problem. Before trying the deb packages there is a gimp-python appimage, which is worth a try.


Plenty of dpkg fails and broken packages presumably from previous tinkering, took a bit of fixing. I did install the gmic package only on the basis it pulls in a raft of dependencies.

Gimp python is there and working. Tried out resynthesizer / heal-selection. Gimp gmic is the old 2.4.5 version but the 'buster' gimp_gmic_qt (curently 2.9) from  supercedes it and works.

All in a kubuntu 20.04 VM  

Thanks again.
Edit: I had the otto...ppa enabled in the repo list which caused problems.  Got rid of that and then in a clean but updated (k)ubuntu 20.04

A recap.

Installed Gimp 2.10.18 (and gave it a run to check it - no python)
sudo apt install gimp

Installed python 2.7
sudo apt install python2.7
sudo apt install python-is-python2

Then pulled in those python packages
sudo apt install python python-cairo python-gobject-2

Downloaded the gimp-python packages

edit: These seem to have gone so, attached in the zip file.

Installed them
sudo dpkg -i *.deb

and that worked fine.

For gimp_gmic_qt the zip from unzipped and in the user profile plug-ins folder worked but this is a kubuntu and the QT packages are already installed. Regular ubuntu users need to check and install.

Attached Files
.zip (Size: 745.06 KB / Downloads: 1,638)

Forum Jump: