Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Heal transparency (resynthesizer plug-in) Error
Hello everyone,

I need help with the resynthesizer plug-in and in particular Heal transparency code. It works perfectly fine with all my images except for a new batch that i received recently. The error and messages are:
GIMP Message:
  1. Plug-in 'Heal selection' left image undo in inconsistent state, closing open undo groups.
  2. Plug-in crashed: "resynthesizer" (/home/ariotta/.config/GIMP/2.10/plug-ins/resynthesizer) The dying plug-in may have messed up GIMP's internal state. You may want to save your images and restart GIMP to be on the safe side.
  3. Calling error for procedure 'plug-in-resynthesizer': Procedure 'plug-in-resynthesizer' returned no return values
An error occurred running python_fu_heal_transparency:
File "/usr/lib/gimp/2.0/python/", line 740, in response dialog.res = run_script(params) File "/usr/lib/gimp/2.0/python/", line 361, in run_script return apply(function, params) File "/home/ariotta/.config/GIMP/2.10/plug-ins/", line 59, in heal_transparency pdb.python_fu_heal_selection(timg, tdrawable, samplingRadiusParam, 0, orderParam, run_mode=RUN_NONINTERACTIVE) RuntimeError: execution error

Someone know what could be?
Thank you in advance!

Any chance of one of the new batch of images that cause the error ?

and generally: Have you updated Gimp recently ? Which version? Which linux ?

Line 59 is calling the heal-selection plugin. Is still installed and executable ?
 # Call heal selection (not the resynthesizer), which will create a proper corpus.
 # 0 = sample from all around
 pdb.python_fu_heal_selection(timg, tdrawable, samplingRadiusParam, 0, orderParam, run_mode=RUN_NONINTERACTIVE)
OK, I can get similar error if the heal-selection plugin is disabled / missing.


Edit: Try a different version of perhaps. One from here:
Hello and thank you for your answer!

well, I use a Ubuntu system and GIMP 10.2. I reinstalled everything but I am sure that it works because I tried it again with older images.
I was thinking that the problems were the new images, but I do not get because I can works with them in python or in imaje without problem and then they crash on gimp.

Finally the error is not exactly the same because I have: "RuntimeError: execution error" and not "procedure not found".

Anyway good idea to try other version of heal transparency, I will try it! Smile
Quote:I was thinking that the problems were the new images, but I do not get because I can works with them in python or in imaje without problem and then they crash on gimp.

From your description the new images are the problem. What image format are they and do they open ok in Gimp ?

Can you run the resynthesizer plugin Filters -> Map -> Resynthesize on its own on a 'problem' image.

Just for background information, is your Gimp installation a flatpak / snap / or from a PPA ?
Hi @rich2005,
i recently installed the plugin resynthesizer tool and while i was working on an old image and was healing it. I started of by using the the 300 dpi scanned image but it became too pixelated to work in detail so i re scanned the same image at 3200 dpi. It opened fine in gimp all the tools are working but as soon as i try to use the resynthesizer tool it shows "plugin returned no return values"
and i already tried whatever you suggested
Pls help i need to restore this image as soon as possible
What operating system ? (Windows / Mac / linux )

and where did you get the resynthesizer and heal - plugins.

I have never seen that error message, so you need to give more information. Are you using one of the python plugins that comes with resynthesizer heal-selection / heal-transparency or of the others
Are you running the resynthesizer plugin alone, maybe making a tilable pattern ?

Scanned at 3200 ppi - that is well over the odds. What size is the image ?

Have you tried whatever operation you are doing on a small test image ? Please post a screenshot showing the part of the image being processed + layers dialogue.

Edit: I did find a report with that error message see:
but no resulting fix or explanation. I suspect it is the version of resynthesizer Did you get it from that Davies media reference ?

Try replacing resynthesizer.exe & resynthesizer-gui.exe with one from this page:

Forum Jump: