Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hillustrative script-fu error
Dear All—

I run GIMP on two Macs, in El Capitan (Mac OS 10.11.6). I realize most GIMP users are not Mac heads... Rolleyes

An article on hyper-realistic photos (link is in the next paragraph) on really caught my interest. However, when I downloaded and installed the script to produce the frequency separation layers: hillustrative-2.8.scm, only one layer gets created in GIMP 2.9 and 2.10. Then it crashes.


The script can be downloaded here:

I wonder if  anyone has experienced this?

These events take place  upon running the Script-Fu script Hillustrative:

The Blur layer is created, then:


GIMP Message

Execution error for ‘Hillustrative’;

Error: event: unbound variable: plut-in-gmic

Upon closing this error message, another error message is revealed underneath it:

GIMP Message

‘Hillustrative’ left image undo in unbound state: closing open undo groups.
Syntax for calling G'MIC has changed:
for instance the procedure to call it is now plug-in-gmic-qt
and also the parameters list has changed
Your other post seems to indicate that you have gmic_gimp_qt in your Mac Gimp - is that correct?

There is a qt Hillustrative script. Attached - unzip it.

This in a linux Gimp 2.8.22 - got the four layers.


Also tried it against the latest gmic_gimp_qt 2.5.2 (compiled this morning) in Gimp 2.10 and it works there as well.

Attached Files
.zip (Size: 1.37 KB / Downloads: 62)

Many thanks for your reply.

I am trying to find my way through the GIMP/G'MIC forrest. As you know, it's pretty different from understanding and using commercial software.

I've been installing Partha's builds of GIMP for the Mac because he includes Nufraw, which I need to open .RW2 files from my Panasonic camera. I have yet to understand how to update or configure G'MIC.

GIMP 2.10 on my laptop seems to have included G'MIC more or less seamlessly, displaying the filter options under the Filters menu in the title bar. On the desktop machine, GIMP 2.9 has an entry for G'MIC in the list of available filters.

Oh well; more coffee, and time spent in front of computers will probably fix things up.
It is a script, it should work with your Mac. All depends on your version of gmic-gimp, is it the QT version or is it the GTK version? As dinasset pointed out the syntax changed with QT and also changes between between QT svn's (just to confuse the user)

Tried out the old 2.8 script with a GTK version and it generates errors, so needs a bit of work.
Hi Rich—

On a Mac Pro tower I am running GIMP 2.9. The title bar of the G'MIC window shows this:

G’MIC for CIMP 2.9 - Mac OS 64 bits - 2.0.3_pre#170821

There are 489 available filters. (!)

Wouldn't you know the syntax for QT would be different.


I'm on Windows, and I use the most recent Samj's portable Gimp.
But if you like you may try this version of hillustrator: it's your ported to 2.10.
Maybe it runs on your system...

.7z   hillustrative.7z (Size: 1.13 KB / Downloads: 65)

Unzip and place in your scripts folder.

Forum Jump: