Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to add spacing between UI elements?
Hello, Im sort of new to GIMP here. After installing it on my Win10, all the UI elements seem to be cluttered and really close together, it is pretty hard to navigate within such a cluttered UI. Is there a way to add more spacing somehow? I saw other screenshots from Gimp and there the UI looks fine, but for some reason all the spacing is gone on my computer. Using the latest version of GIMP (2.10)
I added a screenshot of how cluttered the UI appears.

Attached Files Image(s)
EDIT: I just noticed in your profile you are using Gimp 3? If so, then scratch everything I said below. Those are for Gimp 2.10.1x (is Gimp 3 really released? Or are you using a nighty version still in development? Gimp 3 will use CSS for stylizing the UI).

Hello Mirek,

this is how Gimp looks for me too with the default Dark theme on Windows. I'm not sure what spacing you expected, but showing us some of those other screenshots you mentioned, where the UI looked fine, would help us see what you mean. Maybe they were using a different theme.

The Gimp UI is controlled by the currently active theme, via a text file called: gtkrc (it is located inside the theme's folder, in your hard-disk). The default themes shipping with Gimp 2.10.1x, are additionally using images for several UI elements, stored in a sub-folder called: ui\). You can change the current theme from within Gimp, via Edit -> Preferences | Interface | Theme. By default, Gimp now ships with 3 themes: Dark, Gray and Light.

Anyway, I was not happy with the default themes either (at least on Windows, I have no idea how it looks on Linux, but I guess it shouldn't look much different). So I started ported to Gimp 2.10.1x some themes I had made a long time ago for Gimp 2.8. Yesterday I posted a release-candidate version of my Dark (Blue) theme, in this post:

Give it a try and see if you like it better than the default theme. Make sure you read the Installation instructions, especially for the Clearlooks theme-engine  (my themes need that engine, which doesn't ship with Gimp - without it, the themes will look broken).
You possibly want something like this:

The Tools in Gimp 2.10.20 by default are in Groups. You can go back to one-icon = one tool Edit- > Preferences -> Toolbox and untick Use tool groups


You might want to make the Icons larger; Edit -> Preferences -> Icon Theme choose Custom Icon Size and use the slider.


If you decide to keep the tool groups, easy to use, hover the mouse over the tool-group and scroll  example
Thanks for the suggestions. Unfortunately this seems to be some kind of Win10 problem and it doesn't seem like there is a solution for 2.10 right now. I guess 3.0 might solve the problem in the future with different approach to the layout
I think you'll find it's the symbolic icons as they have been made to fit the space better as there have been complaints about wasted screen real-estate.

You might find the Legacy Icon Theme to be more readable:

Forum Jump: