Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to change interface language?
#1
Have just installed Gimp 2.10.22.  Cannot find the button to change the interface language.  
Help, please.
Thanks.
Kuen
Reply
#2
It menu is Edit -> Preferences -> Interface and a drop down menu under Language. https://i.imgur.com/aw2U00a.jpg

There are video demos around, this one is ok. https://www.youtube.com/watch?v=FlDCa8dk4hM

If you find that there is only one language listed in the list, then that is Gimp set up with translations disabled.
Reply
#3
(11-25-2020, 09:03 AM)rich2005 Wrote: It menu is Edit -> Preferences -> Interface and a drop down menu under Language. https://i.imgur.com/aw2U00a.jpg

There are video demos around, this one is ok. https://www.youtube.com/watch?v=FlDCa8dk4hM

If you find that there is only one language listed in the list, then that is Gimp set up with translations disabled.

Thank you.  I have changed the interface language.
Kuen
Reply
#4
Hello, I have similar issue.
Gimp ignore language config (screenshot):
http://joxi.ru/823oEvXT8qRjN2
And I don't see in verbose output request any lang (*.mo) files.
Gimp version 2.10.22
Windows 10 Pro ver. 20H2 OS 19042.685
Any Ideas?
Thank You
Reply
#5
I can not replicate that, it might be your Gimp installation or the way your Windows installation is set up.

First some checks. This is a regular Gimp 2.10.22
In C:\Program Files\GIMP 2\share do you have a locale folder (1) ? In the locale folder a lot of language folders including a folder ru (2) that contains all those .mo files
In Edit -> Preferences -> Interface then Language drop down there is a ru entry ? Selecting that, (3) Click OK, restart Gimp changes the language.

   

The setting is held in your Gimp user profile C:\Users\"yourname"\AppData\Roaming\GIMP\2.10\ in a file gimprc (4)  You can always delete this file and revert to a default Gimp interface (and start again)

   

If for any reason you do not have that locale folder try a new gimp install (5)  using Customize options (6) where there is an option to include translations (7). I usually miss this one out and save 130 MB disk space but if you need more languages enable the option. 

   
Reply
#6
Thanks for Reply.
Sorry for my not a quick answer.

I checked locale folder, all files present:

   

Checked gimprc file (C:\Users\VITALIY\AppData\Roaming\GIMP\2.10):

   

Looks like all fine. A also tried to start gimp with admin rights, but it does not help.
For double check I changed icons template:

   

and, as You can see, that settings works fine and saved in gimprc file (on screen below)
I also tried start gimp with some debug output, but looks like there no such feature ...

   

Oh, forgot about --verbose
But there are no any errors, except:
Trying splash 'C:\Users\VITALIY\AppData\Roaming\GIMP\2.10\gimp-splash.png' ... failed

   

But all debug below looks fine... ))
I don`t know where could be difference between Yours and mine situation...))
Reply
#7
Do you have Russian selected in Edit -> Preferences -> Interface and the drop down menu in Language ?
This is my setup for English 

   

If you have Russian selected, then sorry I do not know what is wrong with your installation.
Note. The theme has no effect on language.

You could try a re-installation. Uninstall Gimp, delete  C:\Users\"yourname"\AppData\Roaming\GIMP\2.10   and if C:\Program Files\GIMP 2\ remains after the uninstall delete that as well. Reinstall using Russian
Reply


Forum Jump: