Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to install Gimp Heal Plugin (Linux)?

I have Linux MX 18.1.

I would like to install the Heal tool (and all other tools coming with it) included in the Resynthesizer package:

As described, I installed gimp-plugin-registry from the repository. I can see now many new plugins in my Gimp 2.10.8, for example the resynthesizer module. I can use it without any issues.

But under Enhance are not new tools. No heal tool, no uncrop, no sharpen, no enlarge.

I tried to copy the plugin py files manually into the plugin folders (under home and under usr) and made them executable. It did not help, still no heal tool.

I tried search for a solution, but most threads about that topic are 5 years old.
(03-16-2019, 05:14 PM)ciararseeley Wrote: ..snip... installed gimp-plugin-registry from the repository. ....

Go and uninstall it, it is ancient and flaky.

Once uninstalled, go here,

Get the zip, unzip, put the four files in your Gimp profile ~/.config/GIMP/2.10/plug-ins/ check that they are executable.
I uninstalled gimp-plugin-registry. And I put the files into the appropriate folder. I tried it with the files in the linked thread, and also with the files directly from Github. I made the files executable with chmod +x.
But just as before, under Filters - Map I can see the Resynthesizer tool, so that's working.
But under Filter - Enhance there is no heal tool Undecided

Do I need to make proper "executable" files, the two icons on the bottom right? So I need to compile the Python Scripts? I need a Python compiler? That's what's meant with "make the executable"? And not chmod +x?

Sorry, I am semi-new in Linux, so I don't know how to work with scripts and I am not too familiar with "executable" files.

[Image: EgoseqK.jpg]
These days no need to mess around with chmod, at least for Gimp plugins.

In the file browser make sure hidden files are enabled. Go to the Gimp profile folder ~./config/GIMP/2.10/plug-ins where the files are. Just as your screenshot.
Right click on a file. Choose Properties. In the file properties select the Permissions tab. Tick on Allow executing file as a program if not already ticked.


However I can see one problem straight away from your screenshot. Bottom of the Filters Menu there should be a Python-fu entry next to Script-fu. Like this:


That is just to check that it is working. No need to compile anything. All Gimp scripts and plugins are run from the Gimp menu system.
No python, no working python plugins.  I think this is an issue with a Default Gimp 2.10.xx (2.10.6 ??) from the most recent repo. where python support has to be installed separately. In a console try;

sudo apt install gimp-python

An alternative is install Gimp from the PPA Gimp 2.10.8 as the one shown in my screenshots.
IT WORKED!!! Super awesome!!! The gimp-python was the solution! Thank you so much!!!
Thanks again Rich2005, this was the solution for my problem too.

Forum Jump: