Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Overactive colorization problem
#1
I recently upgraded to Gimp 2.10.8, coming from 2.6 (or 2.8, unsure). Ever since then, several functions pertaining to the different color modes do not work right. If I use overlay, lighten, darken, hue, etc, empty area will be filled as if I were using a regular mode brush, while the solid areas experience the effect. When using tablet, pen pressure sensitivity of the pen worked only once, during the session I had activated it; in later session it is switched to active but doesn't work.

This all worked without any problems on the previous version. Might this be a problem of computer settings, or there anything else I can do to fix it?
Reply
#2
Pressure Sensitivity is currently broken.
Reply
#3
Okay. Is there no information on the other issue?
Reply
#4
(12-02-2018, 01:06 PM)Churys Wrote: Ever since then, several functions pertaining to the different color modes do not work right. If I use overlay, lighten, darken, hue, etc, empty area will be filled as if I were using a regular mode brush, while the solid areas experience the effect.

Im not sure what you are talking about...

Color Modes as in Color Management or Layer Modes ?

In 2.10:
when i paint with a brush on a transparent layer in Multiply mode, the color has no mode applied.
However when i paint on an opaque layer (like solid noise for example) with the Multiply mode on, the paint blends as expected.

in 2.8:
when i paint on a transparent layer with a layer mode attached to the brush, nothing happens
when i paint on a solid noise layer, the paint blends as in 2.10
Reply
#5
Thank you for sharing
Reply
#6
If I have a transparent layer in normal mode, and a brush in normal mode, and paint something on the canvas, that works as it should. But if I set the brush to modify that element I just painted, like overlay or lightened, the colored element is normally modified but any transparent area is filled is if normal mode brush had just been applied to it. In the previous version, any transparent area around the filled part was unaffected by applying the brush in overlay/lighten/etc.
Reply
#7
(12-06-2018, 05:11 PM)Churys Wrote: But if I set the brush to modify that element I just painted, like overlay or lightened, the colored element is normally modified but any transparent area is filled is if normal mode brush had just been applied to it.

Isnt that how its supposed to be ?

Painting on a transparent layer provides no pixels the layermode can interact with, so it just paints the colour without any modification.
Reply
#8
No, it's not because when in modification mode it's supposed to modify, not paint. This worked in all previous versions. If there is nothing to lay over, or lighten, or otherwise modify, then it should not be adding anything. Transparent space should stay transparent.

Before, I was able to paint and quickly alter the color of anything to make it more intense, or darker, whatever was needed. Now I have to do all this extra erasing to remove the extra pixels that appear in the transparent area.
Reply
#9
(12-07-2018, 02:39 AM)Churys Wrote: No, it's not because when in modification mode it's supposed to modify, not paint. This worked in all previous versions. If there is nothing to lay over, or lighten, or otherwise modify, then it should not be adding anything. Transparent space should stay transparent.

I guess the developers decided otherwise. The choice seems logical to me.

(btw: i dont get this behaviour you describe in 2.8, so they must have changed it before the switch to 2.10)

Quote:Before, I was able to paint and quickly alter the color of anything to make it more intense, or darker, whatever was needed. Now I have to do all this extra erasing to remove the extra pixels that appear in the transparent area.

You can lock the alpha channel to prevent the brush from overpainting.
For making stuff brighter or darker, the dodge/burn tool is an option.
Reply
#10
Could be a change, could be a bug. If you use the "Legacy" modes (small auxiliary selector at the end of the mode selector) you still have the 2.8 behavior.
Reply


Forum Jump: