Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Plug-in missing
#1
The 'follow-path5.py' plug-in, used it in GIMP 2.10.22 the other day, no issues... today it's not even showing there, i.e. Vectors ➤ Tools ➤ Follow Path
It's definitely in the plug-ins folder (App Data\Roaming..) and the folder preferences are pointing to the correct directories so... ??
Any ideas ('cos I'm stumped!)
Thanks.
Reply
#2
Is it present in the pluginrc file (a sibling of the plug-ins folder)? Is you python support still OK (Filters ➤ Python-fu present)?
Reply
#3
Is this the two part plugin,  (follow-path5.py + gimpfu3.py) or the tweaked single file follow-path5.py ? 

Using a basic Win10 VM and a new install Gimp 2.10.24 (follow-path5.py + gimpfu3.py) does not show in the paths dock, while the single file version follow-path5.py does show and works (sort of) 

   

The preview does not preview and generates lots of error messages which can be annoying.

Otherwise, I do not know. The usual question, was working before, not working now, what changed ?
Reply
#4
(04-23-2021, 12:16 PM)Ofnuts Wrote: Is it present in the pluginrc file (a sibling of the plug-ins folder)? Is you python support still OK (Filters ➤ Python-fu present)?

No, now that I just checked, can't find it in pluginrc, but python support is still there, yes.
@rich - it's the 'follow-path5.py + gimpfu3.py' version, both files are in the correct folder, nothing changed as far as I can recall...
so, I assume it may have to do with the pluginrc file Ofnuts mentioned?
Reply
#5
Quote:...so, I assume it may have to do with the pluginrc file Ofnuts mentioned?

No..although it never does any harm to delete that file and let Gimp create a new one when Gimp is started.

Quote:..it's the 'follow-path5.py + gimpfu3.py' version, both files are in the correct folder, nothing changed as far as I can recall...

It is that version (follow-path5.py + gimpfu3.py) that is the problem. Remove it, both files, and use the single file follow-path5.py attached.

Since the preview no longer works and generates errors also attached as an alternative is the earlier follow-path3.py (also tweaked to remove the troublesome gimpfu.py  dependency). That version looks like this, functionality is much the same as version 5.

   


Attached Files
.zip   follow-path5.zip (Size: 12.24 KB / Downloads: 48)
.zip   follow-path3.zip (Size: 8.45 KB / Downloads: 42)
Reply
#6
" It is that version (follow-path5.py + gimpfu3.py) that is the problem. Remove it, both files, and use the single file follow-path5.py attached.

Since the preview no longer works and generates errors also attached as an alternative is the earlier follow-path3.py (also tweaked to remove the troublesome gimpfu.py dependency). That version looks like this, functionality is much the same as version 5. "



Thanks but I'm still not sure why that happened, like I said nothing changed that I know of, I was using the version (follow-path5.py + gimpfu3.py) - and it looked just like your first screenshot and I also had no preview problems (as long as I had clicked the up/down arrow on 'Copies') - so quite bizarre I must say.
Almost as bizarre as this pleasant weather lol.. anyway thanks again, I'll let you know how I get on. Smile
Reply
#7
Well anyway, seven months later... I'm using 2.10.28 from the main site and both follow-path's (when tested seperately along with gimpfu3.py) work pretty well (apart from no preview and error messages in 'folow-path5'), without gimpfu3 and both act up!
Cheers!
Reply


Forum Jump: