Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Python not working in 2.10.0 Windows
No, it worked in 2.8. Just not in 2.10.
Same here. it's the first time im using Gimp because i need the Python Automation so i installed gimp 2.10 but if i click on "Python FU -> Console" nothing happens no error nothing.
I tried:

Install Gimp 2.10 again
Start Gimp as Admin
Start Gimp with different Compatibility options

But nothing
I have Windows 10 64bit
Did you try also samj's portable pack (64bits)?
I can click on Python-fu/Console and I get the input window
I can't even access the Python-Fu Console.
(05-12-2018, 04:19 AM)dinasset Wrote: Did you try also samj's portable pack (64bits)?
I can click on Python-fu/Console and I get the input window

Yes samj's portable pack works thank you.
Had the same issue on 2.10 (Windows 10 1803/64bit), clicking on the Python-fu console does nothing. Tried reinstalling, definitely have python included in the install, no change.

Using samj's portable pack works for me too so thanks for that suggestion.
Got it to work on a non-portable install too. FYI for anyone having this issue, had to go back to the 2.10 installer from 28Apr18 ("gimp-2.10.0-x64-setup", available on, the latest installer I was using "gimp-2.10.0-setup-1" from 04May18 seems to have an issue with python as well as directory access issues detailed elsewhere. Now the python console and plugins like export layer work fine.
The 2.10 x64 installer from 28-Apr-2018 is the version I used, where Python support is not working for me.

The samj portable pack does seem to have working Python support, though.
I just installed 2.10.2 Windows. Now my Python scripts load and run, but they're crashing sometimes, and the Python-Fu Console does not open. It shows in the menu, but the console window doesn't open.
Are you using a 32 bit or a 64 bit Windows?

Not saying that the Windows Gimp 2.10.2 is not flaky, however are you sure that the installation did not pick up some properties/old files from the previous installation(s).

I would give it one more try. Uninstall Gimp from the Windows uninstall menu. Check that C:\Program Files\GIMP 2 has gone, if not delete it.
Rename your old Gimp 2.8 profile to disable it. Delete the new Gimp 2.10 profile.

The Gimp installer gimp-2.10.2-setup.exe should be 156,710,592 bytes in size, anything else, download a new copy.

Forum Jump: