Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resynthesizer for 2.10.24 - how to add plugin?
#1
I have GIMP 2.10.24 (flatpack) running on Linux Mint 20.1 Cinnamon.
I have downloaded what I believe to be the correct version of Resynthesizer and extracted the files into the "Downloads" folder.
However, when I try to locate the Plugins folder, I get a message that it doesn't exist.  This is by going to Edit>Preferences>Folders>Plug-ins and then clicking on the "Show file location in the file manager" button.
I've tried looking for it manually, but to no avail, and yes I've pressed Ctrl + H to show hidden files.

Question:  Has anyone successfully added the plugin to GIMP 2.10.24?

If you have, please can you tell me how you did it and where you got the Resynthesizer package from?
Thank you in anticipation of a positive response.
Reply
#2
Quote:I have GIMP 2.10.24 (flatpack) running on Linux Mint 20.1 Cinnamon....snip...Question:  Has anyone successfully added the (resynthesizer) plugin to GIMP 2.10.24?

Not a great lover of flatpak Gimp seemed unnecessarily restrictive. Tried some time ago and discarded, time to try again, things have changed.  

   

The basics:

(1) flatpak list  Does just that, lists what is installed. 

(2) flatpak search org.gimp.GIMP.plugin Lists the available flatpak'd plugins for Gimp. Used to be a single option, now with version options. To continue...

(3) flatpak install org.gimp.GIMP.Plugin.Resynthesizer Gives an option to choose the version. I tries both of these (for reasons later) This is the number 2 choice and says installation complete.

If that works for you, great. There should be a resynthesizer option in File -> Map and the 'heal' plugin entries in File -> Enhance.

Snag. Neither of the resynthesizer versions, showed in Gimp. I do not know why. (edit: I looks like it is a bug https://github.com/flatpak/flatpak/issues/4208 )

A bit of digging and the resynthesizer files are installed in
/var/lib/flatpak/runtime/org.gimp.GIMP.Plugin.Resynthesizer/x86_64/2-3.36/active/files/plug-ins/
Copied the files from there to the flatpak user plug-ins folder
/home/your-name/.var/app/org.gimp.GIMP/config/GIMP/2.10/plug-ins/
Ten files in all.

   

And that got it working.  

   

If you try this:
Which resynthesizer version used (1) or (2) ?
Did it work out-of-the-box ?
Did you need to copy the files to your user profile?

-------------------
Edit: Tried uninstalling the flatpak resynth package, leaving the 10 files in user profile. Resynthesize still working here
try:
Download the attached flatpak-resynth.zip Unzip, put the 10 files in 
/home/your-name/.var/app/org.gimp.GIMP/config/GIMP/2.10/plug-ins/


Attached Files
.zip   flatpak-resynth.zip (Size: 132.58 KB / Downloads: 46)
Reply
#3
Thank you for your extensive reply.
I used version 1 and it works - much appreciated.
Reply


Forum Jump: