Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Unbind F1 key
How can I remove the F1 shortcut in GIMP 2.10?
I used to have a snippet in gtkrc inside GIMP's config which disabled the F1 shortcut, which I could then use for something else. This is the snippet:

binding "gimp-help-binding" {
unbind "F1"
class "GtkWidget" binding "gimp-help-binding"

But now after upgrading to 2.10 it doesn't work anymore. Does anyone have an idea why and how I could unbind F1 again? Why isn't it possible to do so within the menu?
This the same as previously in Gimp 2.8 

You can add (use-help no) to the end of your ~/.config/GIMP/2.10/gimprc file which disables F1 in Gimp 

like this:


Might / might not work
What linux/DE are you using? In KDE setting F1 to some other use, over-rides Gimp anyway.

edit: hmm..I see trying to set a shortcut within Gimp to F1 still brings up a 'F1 cannot be re-mapped'.
Back to the drawing board. Hopefully on of the clever guys will come up with a solution.
Thanks for the hint. I used the (use-help no) to disable the help from showing up.

You were right about being unable to map anything to F1 from inside GIMP. However I looked at my old config file and found that there was a line specifying the binding for F1. I copied it into my new, fresh 2.10 config file and it's working.

This is what I have in menurc:

(gtk_accel_path "<Actions>/image/image-new" "F1")

Why is the remapping of F1 disallowed from within GIMP, but allowed using this approach? It's kind of inconsistent. Should I bring this up on the official GIMP bug tracker or is there a reason for this behaviour?

Forum Jump: