Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Scripts not working in Gimp 2.10.2 version
#1
OS Windows 10
Gimp version 2.10.2

None of my addon scripts not working. I'm getting an execution error message: ( :1) eval: unbound variable: NORMAL-MODE. Please can someone help? I have quite a few script I don't want to get rid off yet. Thank you in advance.


Attached Files Thumbnail(s)
   
Reply
#2
Not all old scripts work in 2.10. I have found 2 that don't work.

Which script are you referring to?
I found this:
http://registry.gimp.org/node/24798
and it works in my 2.10
Reply
#3
Do these scripts have an identified author and are you using the latest versions?
Reply
#4
If the errors are of the type shown (mode of a layer) you have likely to start Gimp in "compatibility" mode (but I don't know how to do that, someone else can help you)
Reply
#5
(05-27-2018, 04:36 PM)Ofnuts Wrote: Do these scripts have an identified author and are you using the latest versions?

Unless Pocholo has something newer, most recent version was when the script was 'fixed' for Gimp 2.4 Wink

It works for me about 1 shot in 10. When it fails all you can do is reload the scripts and try again.

[Image: Ld2jvE3.jpg]

Attached for anyone willing to give it a try. I updated some of the layer modes but that is all.


Attached Files
.zip   starrysky.scm.zip (Size: 1.95 KB / Downloads: 6)
Reply
#6
Sorry for the late respond, guys and thank you for taking your time to answer my question.

@Blighty   the answer is no. I have that one also and it's not working either. I have "Starry sky"

@ofnuts  the answer is yes and yes

@rich2005   the answer is I have the latest of that script and it was redefined by GnuTux from gimpscript.


I re- installed Gimp again and still have the same problems with the scripts. 
This version is so wonderful in many of other areas and so, but I'm leaning to go back to the 2.8.22 version where I have everything working. Maybe I'll comeback to this version when all this problems get fix.
                                                                                                       Chiao
Reply
#7
(05-28-2018, 01:26 AM)Pocholo Wrote: @ofnuts  the answer is yes and yes

So the Right Thing to do is to get in touch with the author and report the problem to him/her.
Reply
#8
(05-28-2018, 05:54 AM)Ofnuts Wrote:
(05-28-2018, 01:26 AM)Pocholo Wrote: @ofnuts  the answer is yes and yes

So the Right Thing to do is to get in touch with the author and report the problem to him/her.

Might be difficult: for starry-night.scm

Quote:version 1.01  2006.07.11
; version 1.10  2007.10.24 - Migration to Gimp 2.4
; version 1.20  2014.09.01 - Ensure compatibility with GIMP 2.6.x & 2.8.x (GnuTux)

Considering GnuTux retired due to ill health and GimpScripts down since then, best of luck.

@Pocholo
I can get that version working (just) about 1 time in 10, same as before. Can not see much difference apart from the menu location. Not worth bothering with.

I remarked about all the old scripts transferred when you installed Gimp 2.10
FxFoundry, GAP etc. IMHO The best way to use these is Gimp 2.8, keep going with that. Probably you will never need the 'extras' that Gimp 2.10 provides.
Reply
#9
I gave it a try but am stuck:
I started GIMP with --pdb-compat-mode=warn so I get info on what is no longer valid.
This is what it said:


Code:
 GIMP Warnung
Plug-in "script-fu"
(/app/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-undo-push-group-start'.
It should call 'gimp-image-undo-group-start' instead!

 GIMP Warnung
Plug-in "script-fu"
(/app/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-palette-set-foreground'.
It should call 'gimp-context-set-foreground' instead!

 GIMP Warnung
WARNING: Plug-in "script-fu"
(/app/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-image-add-layer'.
It should call 'gimp-image-insert-layer' instead!

 GIMP Warnung
Plug-in "script-fu"
(/app/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-image-lower-layer-to-bottom'.
It should call 'gimp-image-lower-item-to-bottom' instead!

 GIMP Warnung
WARNING: Plug-in "script-fu"
(/app/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-image-add-layer'.
It should call 'gimp-image-insert-layer' instead!

 GIMP Warnung
WARNING: Plug-in "script-fu"
(/app/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-image-add-layer'.
It should call 'gimp-image-insert-layer' instead!

 GIMP Warnung
WARNING: Plug-in "script-fu"
(/app/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-image-add-layer'.
It should call 'gimp-image-insert-layer' instead!

 GIMP Warnung
WARNING: Plug-in "script-fu"
(/app/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-levels'.
It should call 'gimp-drawable-levels' instead!

 GIMP Warnung
WARNING: Plug-in "script-fu"
(/app/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-colorize'.
It should call 'gimp-drawable-colorize-hsl' instead!

 GIMP Warnung
Plug-in "script-fu"
(/app/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-layer-set-name'.
It should call 'gimp-item-set-name' instead!

 GIMP Warnung
Plug-in "script-fu"
(/app/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-layer-set-name'.
It should call 'gimp-item-set-name' instead!

 GIMP Warnung
Plug-in "script-fu"
(/app/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-layer-set-name'.
It should call 'gimp-item-set-name' instead!

 GIMP Warnung
Plug-in "script-fu"
(/app/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-layer-set-name'.
It should call 'gimp-item-set-name' instead!

 GIMP Warnung
Plug-in "script-fu"
(/app/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-undo-push-group-end'.
It should call 'gimp-image-undo-group-end' instead!

Replaced all the occurences as suggested.


And now when running I get the message:
Error: Procedure execution of gimp-drawable-set-pixel failed

I'm stuck now, as I can't imagine what's wrong.
I'll attach the script as it is now. Maybe someone can help.


Attached Files
.zip   starry-sky.scm.zip (Size: 2.2 KB / Downloads: 6)
Reply


Forum Jump: