Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Show Ruler setting is not persistent
main menu > View > Show Rulers:uncheck
restart GIMP
rulers are again displayed

is this setting supposed to be persistent?
Edit > Preferences > Image Windows > Appearance

Uncheck “Show Rulers” in two places: under “Default Appearance in Normal Mode” and “Default Appearance in Fullscreen Mode”
Does that last post mean you have it fixed on your installation?

This a more general way to customize the Gimp 2.10 interface

You can set Gimp 2.10 to open up in the same configuration whenever you open it.

Set up the Gimp windows/dock sizes the way you want. Including having the rulers showing / or not
Choose a tool and tool settings as the one to start with.

In Edit -> Preferences ->

1. Tool Options
Untick Save tool options on exit
Click on Save Tool Options Now

2. Window Management
Untick Save window positions on exit
Click on Save Window Positions Now

3. Input Devices
Click on Reset Saved Input Device Settings to Default Values
Untick Save input device settings on exit
Click on Save Input Device Settings Now

OK that to get out of the Preferences Dialogue. Restart Gimp.

Gimp starts up in the desired configuration.
Thanks Rich. I had the defaults -save [Tool | Window | Input] checked on exit). I would have thought one of these would have therefore saved ruler visibility. Is it a Tool or Window? But anyway, my 2nd post to myself works - Edit > Preferences > Image Windows > Appearance > Uncheck Show Rulers, so happy now.

Forum Jump: