Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tool Snapping not working
#1
Not too long ago I upgraded from GIMP 2.8 to 2.10 (and now to 2.10.6) and now it seems that the Tool Snapping has stopped working.
It doesn't matter what kind of snapping I activate, none of them have a single effect on anything.
I've tried setting the Snapping distance higher, but it also didn't work.

I would appreciate any help.

Edit:
Snapping does still work, but the Snapping distance in the settings and the actual distance while editing aren't the same.
Setting the distance to 64 will result the actual snapping distance to be only 2 pixels.
The ratio of distance in settings and actual distance in editor is 32:1.

Does anybody know how to fix this?
Thanks in advance.
Reply
#2
I can not duplicate the problem. This an all-in-one https://i.imgur.com/dj96VdU.jpg - working here.

Perhaps if you give some actual settings, grid sizes, tool(s) used, snap setting someone will have an answer.

If the worst comes to the worst, disable your old Gimp 2.8 profile so settings are not migrated, rename the new Gimp 2.10 profile as a back-up, then start Gimp 2.10 to create a new default profile.
Reply
#3
(10-27-2018, 03:56 PM)SpEZiiL Wrote: Not too long ago I upgraded from GIMP 2.8 to 2.10 (and now to 2.10.6) and now it seems that the Tool Snapping has stopped working.
It doesn't matter what kind of snapping I activate, none of them have a single effect on anything.
I've tried setting the Snapping distance higher, but it also didn't work.

I would appreciate any help.

Edit:
Snapping does still work, but the Snapping distance in the settings and the actual distance while editing aren't the same.
Setting the distance to 64 will result the actual snapping distance to be only 2 pixels.
The ratio of distance in settings and actual distance in editor is 32:1.

Does anybody know how to fix this?
Thanks in advance.

As far as I can tell, what you set is a physical snapping distance (these are 64 pixels on your screen), in other words the actual  snapping distance in the image will depend on the zoom factor: at 100% it is 64pixels, but if you zoom 32x, it is two pixels in the side rulers.
Reply
#4
(10-27-2018, 04:48 PM)Ofnuts Wrote:
(10-27-2018, 03:56 PM)SpEZiiL Wrote: Not too long ago I upgraded from GIMP 2.8 to 2.10 (and now to 2.10.6) and now it seems that the Tool Snapping has stopped working.
It doesn't matter what kind of snapping I activate, none of them have a single effect on anything.
I've tried setting the Snapping distance higher, but it also didn't work.

I would appreciate any help.

Edit:
Snapping does still work, but the Snapping distance in the settings and the actual distance while editing aren't the same.
Setting the distance to 64 will result the actual snapping distance to be only 2 pixels.
The ratio of distance in settings and actual distance in editor is 32:1.

Does anybody know how to fix this?
Thanks in advance.

As far as I can tell, what you set is a physical snapping distance (these are 64 pixels on your screen), in other words the actual  snapping distance in the image will depend on the zoom factor: at 100% it is 64pixels, but if you zoom 32x, it is two pixels in the side rulers.

That seems to be the case, I didn't know that, thank you.
Is there any way to change this to not be physical but depending on the distance of the pixels in the image, not the display, instead?
Reply
#5
AFAIK you can't and IMHO that would be pointless.The purpose of snapping is to help your hand, and the accuracy of your mouse moves is related to the physical screen.
Reply


Forum Jump: