Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu - how do I update "gimptool-2.0"?
#1
Ubuntu 18.04.


I'm trying to Install BIMP. I managed in 16.04, but in 18.04 I've had a cascade of problems.

First I had errors. Then I read in the BIMP github repository that you now need Gimp version 2.10 or greater.

I did an apt-get remove with a --purge flag of my Gimp version 2.8.22, and installed Gimp 2.10 from the software center.

But the errors persisted.

It seems that my gimptool-2.0 is still on version 2.8.22, but I can't figure out how to upgrade it. I've searched for a while. Any help?


https://github.com/alessandrofrancesconi...issues/200
Reply
#2
Code:
>>>type gimptool
gimptool is /usr/bin/gimptool
>>>realpath /usr/bin/gimptool
/usr/bin/gimptool-2.0
>>>dpkg -S /usr/bin/gimptool-2.0
libgimp2.0-dev: /usr/bin/gimptool-2.0
So you have to update package libgimp2.0-dev. Which Gimp version did you install? Standard from Canonical? From PPA? Flatpak version? AppImage?

Note that updating libgimp2.0-dev should also give you the updated C headers that will define things such as GIMP_LAYER_MODE_NORMAL_LEGACY (new in Gimp 2.10). It is highly probable that gimptool itself didn't receive any code updates (it is mostly a wrapper to call GCC...).
Reply
#3
A lot depends on where the Gimp 2.10 came from. Really need to know that. For 'buntu 18.04 (I have a (k)ubuntu 18.04 on a desktop PC) the default Gimp is 2.8.22 

That gives for Gimp 2.10 a choice: flatpak, snap or from ppa:otto-kesselgulasch/gimp (do not use ppa:otto-kesselgulasch/gimp-edge - the Gimp there is broken)

flatpak and snap are sandboxed and your repo packages will still be for Gimp 2.8 - no upgrades. If using the ppa then libgimp2.0-dev is there and up-gradable.

There is a demo video of compiling BIMP2 here: https://www.gimpusers.com/mailmsg.php?91...pusers.com It is in 'buntu 18.10 but should give some clues. Plenty warnings but no errors. I put the binary there as well.

Bimp has a dependency libpcre3 - do you have that package installed?  There is also a BIMP2 no-pcre3 patch as well.

EDIT: A look at what is current and that no-pcre3 patch has been incorporated along with a fix for a color-curve problem. From 7 days ago. In 'buntu 18.04 same as before - lots of warnings but compiles.

Apart from BIMP2 the previous BIMP1.18 will work. The 2 'versions' are attached. Try out one-at-a-time. Both work in my 'buntu 18.04 Gimp 2.10.8 flatpak (with libpcre3 added to the gnome runtime package) Maybe one works with your installation, but if possible do try a compile and do not worry too much about all those warnings.


Attached Files
.zip   bimp.zip (Size: 197.96 KB / Downloads: 3)
Reply


Forum Jump: