Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
User Interface Icons Missing. 2.10 on W7 Pro
I am having some problems installing Gimp 2.10 under Windows 7 Pro. With the default settings, the Tool Icons and additional User Interface Icons are missing. I can get the Tool Icons to show up by choosing the "Legacy" and "Use Icon Size from Theme" under Edit / Preferences / Interface / Icon Theme, but some of the User Interface Icons are still missing. 


"Legacy" and "Use Icon Size from Theme" under Edit / Preferences / Interface / Icon Theme

I've now tried an install on another, newer computer with a clean install of Windows 7 and it doesn't have the same problem.

I removed as much of the previous installations of 2.8 and 2.10 as possible and did a clean install on the machine I'm having the issue with. Here is what the screen looks like:

Gimp 2.10 uninstalls Gimp 2.8.x on installation but the Gimp 2.8 profile remains. C:\Users\your-name\.gimp-2.8\

Gimp 2.10 will copy parts of this to the new Gimp 10 profile C:\Users\your-name\AppData\Roaming\GIMP\2.10\ for you to place your resources.

If you still have a C:\Users\your-name\.gimp-2.8\ rename it to say C:\Users\your-name\.bak-gimp or back the whole thing up somewhere safe and delete it.

Delete the new profile C:\Users\your-name\AppData\Roaming\GIMP\2.10\ (careful you just delete the GIMP\2.10 bit)

Start Gimp 2.10 up to make a new default, Gimp profile

If that does not work, do not know what the screw-up is.
Thanks, rick2005. I have tried completely removing all of the user data, app data, and program files for both versions of Gimp and reinstalling just 2.10. I even checked the registry to make sure there wasn't something lurking in there. The last photo above shows the result.
I started to use GIMP some years ago, and I was using 2.8.22 just to yesterday. 
I did the same experience as dana_w  with the newest release 2.10 and I confirm that many icons seam to be missing (perhaps, are they too small ? ), especially icons in various UI menus (Cut, past, preferences etc..).
I did any suggestion as rick2005 said in his reply and the final situation is a little bit better, but not completely satisfactory.
So, if there are no other solution to this problem, I will go back to 2.8.22 and I will test sometime the new releases, to check if they are OK. Best regards,

Forum Jump: