Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows: Gimp loading fonts on each startup: possible workaround
#11
(07-05-2018, 03:54 AM)Espermaschine Wrote: Before Gimp 2.8 searched minutes for new fonts evry time i started the program, although nothing new was installed.

Except automatic Windows updates?
Reply
#12
(07-05-2018, 05:56 AM)Ofnuts Wrote: Except automatic Windows updates?

no, i didnt have any win updates in a while
Reply
#13
Thanks for this tip. Just wanted to add that it worked for me with the 'portableapps' portable version of 2.8 (I now have 2.10 as my main install but still use a portable install of 2.8 for various purposes).

The procedure is slightly different, in that the files one has to rename are obviously not found in the user\appdata folder, but in GIMPPortable\Data\fontconfig\cache.

I renamed the files and my first reload still took a while (but shorter than normal, and the .old file was removed) but on subsequent restarts things are very fast now.

Thanks again.
Reply
#14
(02-28-2018, 03:15 PM)Ofnuts Wrote: Gimp displays "Looking for data files / fonts (this may take a while)" on each startup

This is not the normal behavior. See https://bugzilla.gnome.org/show_bug.cgi?id=793918

Gimp should rebuild the font cache only when the fonts are added to/removed from the system.

A possible workaround:
  • Navigate to C:\users\{your id}\AppData\local\fontconfig\cache
  • There should be four files:
    • CACHEDIR.TAG
    • someverylongname (usually 1MB or more)
    • someverylongname.NEW (usually 1MB or more, slightly bigger that the one above if you added fonts)
    • someotherverylongname (small: 1K)
  • rename someverylongname to someverylongname.OLD
  • rename someverylongname.NEW to someverylongname
  • restart Gimp which should no longer rebuild the font cache

If this works for you please confirm below.

Hello! After reading this thread, I seem to have a problem:
- on opening C:\users\{my id} I see a folder .cache, i.e., C:\users\{my id}\.cache, with a folder fontconfig:
C:\users\{my id}\.cache\fontconfig, containing 
  • CACHEDIR.TAG
  • someverylongname.cache-7 (some 1.25MB)
both dating from my Gimp2.10 installation;
- in C:\users\{my id}\AppData\local\fontconfig\cacheI have 41 elements:
  • CACHEDIR.TAG, 2016
  • someverylongname.cache-4 more than 1MB, 2016
  • someverylongname.cache-6 4 items, ranging from more than 1MB to 11KB, all from 2017
  • someverylongname.cache-7 21 items, ranging from more than 1MB (2) to 8KB,  from 2017 and 2018
  • someverylongname.cache-6.NEW 659KB,  from 2017
  • someverylongname.cache-7.NEW 13 items, 1 with more than 1MB (date of Gimp10 installation), the rest ranging from 681KB  to 8KB,  from 2017 and 2018

- Adding to the puzzle, I have running other two programs, also python-based, of which one, at least, uses  fontconfig--BUT NOT the same fonts, being restricted to Windows installed fonts, while Gimp uses as many additional ones, as by Preferences.


My question is: can I safely assume that everything in C:\users\{my id}\AppData\local\fontconfig\cache is Gimp-related and just take the most recent .cache-7and .cache-7.NEW for renaming? And, shouln´t all older items be deleted? No, I am not pressed for space, but having been so in the past, I became trash-conscious. Again, my old 2.8 took an unconscionably long time loading...
Thanks!
Reply
#15
(09-17-2018, 11:33 PM)carmen Wrote: My question is: can I safely assume that everything in C:\users\{my id}\AppData\local\fontconfig\cache is Gimp-related

No, it is not just Gimp related, it is also Windows related. I have found instructions relating to Windows font cache that gives information about these files. If you install a new font in windows these files get messed up and Gimp takes a long time to start. I have also had problems after a windows update.

I just rename the file cache to cacheOLD-01. Gimp takes a long time to start just once after that and then all is good. A new cache file gets created.
Reply
#16
OMG! It worked, you are a genius !  Thanks so much. (Windows 7)

Rick in Vonore, Tn. (We have 2 stoplights now !)
Reply


Forum Jump: