Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fonts Visible In Gimp But Unusable
#1
I've been looking at the 'Why do some fonts have a # at the end and become unusable (under windows, at least)' question.


.webp   Gimp fonts list 02.webp (Size: 5.47 KB / Downloads: 5)

Note:

My basic working set is a commercial, OpenType font family, 'Farmhouse'. I have, as yet, done NO work on other fonts or font formats.
I am NOT (yet - give me a few days) a FontForge expert, nor an expert in fonts, generally. I DO have a techie background, however, and know how to burrow.

After a lot of hacking about (thanks everybody who helped out) FontForge shows me that, in my test OpenType font-set, Gimp picks up the 'Preferred Family' string in TTF Names section of Font Information in FontForge or, if the 'Preferred Family' information is unavailable, it defaults to the PS names 'Family Name' setting in the same FontForge section.

Can Anybody Tell Me Why?

Inspecting the font in Windows' Font Preview option in Windows file explorer, the PS Names>FontName seems to be in use; while the received wisdom seems to be 'it's all down to poor work on the part of the font foundry', it occurs to me that picking up a font family rather than a font name is going to cause difficulties. 

It also occurs to me that the folk that develop Gimp, like Technical People everywhere, Had A Good Reason At The Time (mostly) and that I'm a noob walking in very late to the discussion.

I'm sure people will set me right if I'm asking a dumb question and I accept that these things can be a lot more complicated than they appear on the surface.

In passing, I've knocked together a quick FontForge script to alter (or delete) the 'Preferred Family' section in TTF Names, so I do have a possible workaround for my own system in place for the time being.
Reply


Forum Jump: