Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GMic Disappeared from GIMP 2.10.24 Flatpak Installation - Solved
It is a mystery, it is one of the reasons I am not keen on flatpak, things not working.

Gmic is still bottom of the Filters menu and greyed-out if there is no open image.

FWIW, you can check in the flatpak user profile, in .var and see what is there. If you had gimp_gmic_qt running before then there should be an old gmic folder and it might be worth disabling by renaming and see if a new default is created when you start Gimp.


Just to check what is there from the Edit -> Preferences -> Folders -> Plug-ins You can get to the gmic plugins folder from there and check that the plugin is there and if all those dependencies show.


As you remarked, this did come up on pixls-us and not much joy there either.
Oh emm gee, so this is how I fixed it in Debian 12:

First, it is important to note that the /app directory shown in the preferences doesn't exist "as is" from the root directory:


What GIMP's flatpak interprets as /app may be multiple places but one of them seems to be /var/lib/flatpak/app/ (lots of "maybe" here. I'm no flatpak guru)

From there, if you go in:


you should find the gmic_gimp_qt executable.

For some reason it serves no purpose here. I copied it to


and voilà!

Thank you very much rich2005 for pointing me in the right direction!

Forum Jump: