Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installation error - Gimp 2.10 - gmic plugin
#1
I’llI’m Hi. 
Hoping someone can help. 
I’ve been running Gimp 2.8 with no issue & I’m now trying to install 2.10 but on loading up I get the following message

gmic_gimp_qt.exe - entry point not found


The procedure point g_file_test could not be located in the dynamic link library C:\programme files\gimp2\bin\libgmodule-2.0-0.dll

Gimp still opens but I can’t seem to install GMIC at all. 

Any help will be very much appreciated. 

Thank you
Lisa
Reply
#2
There is a specific installer for gimp_gmic_qt and Windows Gimp 2.10.0

[Image: cLajlja.jpg]

I have tried this and it does work.

My advice:

Since you have already installed Gimp 2.10.0 check that it works ok. There is a fault with the latest installers. see example: https://www.gimp-forum.net/Thread-2-10-C...18#pid8118

If your Gimp 2.10.0 works ok
The installer automatically uninstalled Gimp 2.8 but left the gimp 2.8 profile C:\Users\yourname\.gimp-2.8

Gimp 2.10.0 then copies any resources (including your old gmic) to a new gimp 2.10 profile C:\Users\appdata\roaming\GIMP\2.10

It is best to start with a clean installation
1. Rename C:\Users\yourname\.gimp-2.8 to C:\Users\yourname\.ggimp-2.8
2. Delete C:\Users\appdata\roaming\GIMP\2.10
3. Run Gimp 2.10 to create a new default profile.
4. Install the new gmic
5. Move your old plugins / scripts / brushes ... from C:\Users\yourname\.ggimp-2.8 to C:\Users\appdata\roaming\GIMP\2.10 checking that they work.
Reply
#3
Hi Rich,

I searched my C drive for anything Gimp related and uninstalled / deleted everything I found and started again. I've installed both GIMP 2.10 & GMIC with no problems this morning.

Thank you for your help, much appreciated!
Reply
#4
(05-14-2018, 07:18 PM)rich2005 Wrote: There is a specific installer for gimp_gmic_qt and Windows Gimp 2.10.0

[Image: cLajlja.jpg]

I have tried this and it does work.

My advice:

Since you have already installed Gimp 2.10.0 check that it works ok. There is a fault with the latest installers. see example: https://www.gimp-forum.net/Thread-2-10-C...18#pid8118

If your Gimp 2.10.0 works ok
The installer automatically uninstalled Gimp 2.8 but left the gimp 2.8 profile C:\Users\yourname\.gimp-2.8

Gimp 2.10.0 then copies any resources (including your old gmic) to a new gimp 2.10 profile C:\Users\appdata\roaming\GIMP\2.10

It is best to start with a clean installation
1. Rename C:\Users\yourname\.gimp-2.8 to C:\Users\yourname\.ggimp-2.8
2. Delete C:\Users\appdata\roaming\GIMP\2.10
3. Run Gimp 2.10 to create a new default profile.
4. Install the new gmic
5. Move your old plugins / scripts / brushes ... from C:\Users\yourname\.ggimp-2.8 to C:\Users\appdata\roaming\GIMP\2.10 checking that they work.
Thanks for this Rich2005, it worked perfectly. I have spent hours trying to solve this problem with no joy whatsoever. Could have saved myself heartache coming here earlier!!

Again, many thanks
Reply


Forum Jump: